Перейти к блогу GetChip.net - блог        JilTE[1] - в разработке     Модификации устройств - модификации

 
Текущее время: 07 апр 2020, 20:48

Часовой пояс: UTC + 3 часа [ Летнее время ]



Ответить
Имя пользователя:
Заголовок:
Текст сообщения:
Введите текст вашего сообщения. Длина сообщения в символах не более: 60000

Размер шрифта:
Цвет шрифта
Настройки:
BBCode ВКЛЮЧЁН
[img] ВКЛЮЧЁН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЁН
Смайлики ВЫКЛЮЧЕНЫ
Отключить в этом сообщении BBCode
Не преобразовывать адреса URL в ссылки
Анти-спам
Анти-спам:
Выполните задание
   

Обзор темы - Баги в работе Тюнера.
Автор Сообщение
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
ок.спасибо.
а то я уже хотел ноут на помойку нести ))
Сообщение Добавлено: 16 апр 2014, 14:32
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
Не спешите пока сейчас все активно меняется и базовое устройство выложенное для скачивания будет меняться, так как тюнер уже далеко ушел вперед.
Как подготовлю релиз более менее отлаженный, я сделаю сообщения и здесь на форуме и появятся соответствующие записи на ресурсе ЗиЧип
Сообщение Добавлено: 16 апр 2014, 12:22
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
не совсем уверен,что баг тюнера,но как то не понятно.
пока учусь всему этому,отсюда и непонятки )))
вобщем суть:
прошил китайскую ардуину без USB порта,собрал usb-uart с сайта Getchip.
подключил к компу и ничего...тюнер не видит сеть по этому порту и вообще каких либо устройств.
но! если к компу подключить еще что нибудь типа usb-com (покупной) то в тюнере при выборе нужного компорта сеть видится и всё находится.
правда устройство не автоматом находится,а приходится вручную каждый раз адрес вбивать.

з.ы.не победил. всё так же.
Сообщение Добавлено: 15 апр 2014, 18:57
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
СПАСИБО :lol: :)

Буду тестировать дальше...
Сообщение Добавлено: 30 янв 2014, 06:26
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
ZiB писал(а):
Я помню, но тем речь шла немного о другом.
В идеале в описании элемента добавить бы параметр в котором указывать отображать иконку или нет
и ещё один для задания цвета шрифта.
Тогда я бы на конец "избавился" от этого противного нолика. Указал бы цвет фона и поля одинаковый и отключил иконку, получилась бы "пустая" строка более приятное восприятие:

по поводу ключа отключающего иконку, не уверен, что это будет востребовано. иконки для того и введены, чтобы улучшить читаемость сценария. зачем их отключать? (всегда можно элементу подсунуть дефолтную иконку, пустую или с каким либо символом).
по умолчанию (когда нет у элемента иконки) вставил иконку с менее броским рисунком.

по поводу цвета текста - это классная идея! (как я сам не додумался? :o ). Убиваем сразу трех зайцев, и не ломается общая логика, и прячется нолик для разделителя (вместе со всеми данными остальных столбцов, что еще лучше), плюс подсветку текста можно использовать для разделения элементов по каким либо признакам. В общем сделал изменение цвета элемента.

плюс добавил возможность в палитре элементов вставлять пустые разделители (без ноликов)
Изображение
Сообщение Добавлено: 30 янв 2014, 01:49
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
Цитата:
помнится кто-то говорил что пустая иконка очень мешает видеть, что элемент не прописан XD . та что, таки пустую оставляем?


Я помню, но тем речь шла немного о другом.
В идеале в описании элемента добавить бы параметр в котором указывать отображать иконку или нет :)
и ещё один для задания цвета шрифта.
Тогда я бы на конец "избавился" от этого противного нолика. Указал бы цвет фона и поля одинаковый и отключил иконку, получилась бы "пустая" строка более приятное восприятие:


Вложения:
Безымянный.png
Безымянный.png [ 30.15 КБ | Просмотров: 3113 ]
Сообщение Добавлено: 29 янв 2014, 05:57
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
ZiB писал(а):
Нужно увеличить форму "Установки значения для ТД", чтобы описание "длинное" отображалось корректно:
Галочка "записывать автоматически" при открытии формы думаю должна быть снята, есть точки в которые постоянно писать не нужно.
Сама форма написана фигово и я ее буду полностью переписывать. Пока поменял состояние галочки, а описания устройства у меня вообще нет :crybaby: - новую форму замучу немного по другому (записал в планы) - пока оставлю так

ZiB писал(а):
Ввести проверку вводимых значений времени опроса, а то сейчас можно и отрицательные ввести:
(миллисекунд пишется как "мс", а не "мС" )
сделано.

ZiB писал(а):
По умолчанию сделать шире столбец описания. Двухзначные адреса не отображаются:
сделано

ZiB писал(а):
По дефолту для действий без иконки может просто пустое поле оставить ?
Потому, что очень сильно отвлекает текущая иконка.
помнится кто-то говорил что пустая иконка очень мешает видеть, что элемент не прописан XD . та что, таки пустую оставляем?
Сообщение Добавлено: 28 янв 2014, 21:41
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
По дефолту для действий без иконки может просто пустое поле оставить ?
Потому, что очень сильно отвлекает текущая иконка.


Вложения:
Снимок.PNG
Снимок.PNG [ 11.38 КБ | Просмотров: 4267 ]
Сообщение Добавлено: 28 янв 2014, 18:31
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
По умолчанию сделать шире столбец описания. Двухзначные адреса не отображаются:


Вложения:
Снимок.PNG
Снимок.PNG [ 7.62 КБ | Просмотров: 4269 ]
Сообщение Добавлено: 28 янв 2014, 18:23
  Заголовок сообщения:  Re: Баги в работе Тюнера.  
Цитата
Ввести проверку вводимых значений времени опроса, а то сейчас можно и отрицательные ввести:
(миллисекунд пишется как "мс", а не "мС" :) )


Вложения:
Снимок.PNG
Снимок.PNG [ 16.46 КБ | Просмотров: 4269 ]
Сообщение Добавлено: 28 янв 2014, 18:19

Часовой пояс: UTC + 3 часа [ Летнее время ]


Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB